Identified
Conversations are now displaying correctly again. Text search within conversations isn't working yet, we're actively fixing it and will post another update once it's resolved.
Investigating
We are investigating an issue in the EU Residency where recent conversations are not showing up in history.
The conversation history is not lost; there is just a lag in displaying it.
Please note that this doesn't affect actual conversations; everything is working correctly.
We are working on getting the history back up.