·
Write-up published
Read it here
Resolved
The issue has been resolved. A root cause analysis will be shared shortly.
Monitoring
Latency has returned to baseline levels.
Investigating
We are currently investigating the root cause.