EU Residency Server: Agents Platform Latency Issues
Resolved·Degraded performance

The issue has been fully resolved.

Thu, Jan 15, 2026, 11:40 AM
(19 hours ago)
·
Affected components
Updates

Resolved

The issue has been fully resolved.

Thu, Jan 15, 2026, 11:40 AM

Monitoring

A fix has been deployed, and we are currently monitoring the results.

Thu, Jan 15, 2026, 11:39 AM

Investigating

We are currently investigating the performance issues on the EU Residency Agents platform.

Thu, Jan 15, 2026, 11:10 AM(29 minutes earlier)