Resolved
After careful monitoring and confirmation of current functionality, we have confirmed that Batch Calling functionality is now completely restored.
Monitoring
Some workspaces have been affected by batch call scheduling delays, where calls were not being dispatched uniformly for all workspaces. This resulted in some batch jobs getting stuck in a pending or scheduled state, and calls not being triggered.
Our team has released some targeted adjustments that are resulting in significant improvements, and are currently monitoring the state of batch calling to ensure full resolution.