Increased TTS latency with Eleven Flash v2.5 and Eleven Turbo v2.5
Resolved·Degraded performance

Between 01:55 and 02:00 UTC, our Flash v2.5 and Turbo v2.5 models in the US region experienced a brief period of elevated latency and some expired tasks. The issue has been fully resolved, and requests are operating normally.

Wed, Oct 29, 2025, 05:00 AM
(1 week ago)
·
Affected components
Updates

Resolved

Between 01:55 and 02:00 UTC, our Flash v2.5 and Turbo v2.5 models in the US region experienced a brief period of elevated latency and some expired tasks. The issue has been fully resolved, and requests are operating normally.

Wed, Oct 29, 2025, 05:00 AM

Monitoring

Between 01:55–02:00 UTC, ElevenLabs Flash v2.5 and Turbo v2.5 models in the US experienced slightly elevated latency and some expired tasks. The issue has been resolved, and the team have identified the latency source.

Wed, Oct 29, 2025, 03:10 AM(1 hour earlier)