Higher than normal latency
Resolved·Degraded performance

The issues have now been resolved.

Mon, Sep 29, 2025, 02:59 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

The issues have now been resolved.

Mon, Sep 29, 2025, 02:59 PM

Investigating

We are investigating higher than normal latency affecting some of our requests.

Mon, Sep 29, 2025, 02:41 PM(18 minutes earlier)