Website not loading for some customers
Resolved·Partial outage

According to telemetry and internal testing, the temporary bump in resources was able to alleviate the issue. Additionally, we can confirm that the application load balancer improvement has been completed as well. While we continue to reduce resources back to operational levels and monitor the resources via telemetry, we will mark this incident as resolved.

Tue, Aug 19, 2025, 06:48 AM
(1 week ago)
·
Affected components
Audio Platform (Website)
Updates

Resolved

According to telemetry and internal testing, the temporary bump in resources was able to alleviate the issue. Additionally, we can confirm that the application load balancer improvement has been completed as well. While we continue to reduce resources back to operational levels and monitor the resources via telemetry, we will mark this incident as resolved.

Tue, Aug 19, 2025, 06:48 AM

Monitoring

During a planned reliability improvement to our application load balancers, a configuration issue for api.us.elevenlabs.io resulted in traffic not being properly distributed across all available zones. This led to backend overload and service degradation (primarily for website users).

To temporarily alleviate the issue, we have added additional resources to all the zones until the load balancer configuration can be safely remediated.

Tue, Aug 19, 2025, 06:34 AM(14 minutes earlier)

Investigating

We’re aware that some customers are experiencing issues with the website not loading, and our team is actively investigating the cause.

Tue, Aug 19, 2025, 05:57 AM(36 minutes earlier)