No components marked as affected
Resolved
We've now fully resolved the issue and addressed all requests that were impacted by incorrect charges.
Monitoring
We have deployed a fix to address the issue with incorrect charges being applied. We're continuing to monitor the issue until we are confident all affected requests have been addressed.
Investigating
We've identified an issue where a portion of our requests are being charged at incorrect rates. We're currently deploying a solution.