Resolved
This incident is now resolved. We are continuing to invest in reliability as a core focus and in particular improving how our system handles reduced availability from model providers.
Monitoring
A fix has been released, and we are monitoring the issue
Identified
We have identified an issue with LLM timeouts particularly affecting Gemini 2.5 Flash and GPT4.1 and are monitoring the release of a fix for this regression.