Increased Text-to-Speech Latency
Affected components
Updates

Write-up published

Read it here

Resolved

All performance metrics have returned to normal, and our systems are fully healthy with no further degradation in performance or elevated latency. We consider the incident resolved and will publish an RCA once our investigation concludes.

Thu, Jul 24, 2025, 05:05 PM

Monitoring

We've issued another hotfix that should bring everything back to normal levels. As this rolls out, we'll continue monitoring things to make sure things are looking healthy.

Thu, Jul 24, 2025, 04:47 PM(18 minutes earlier)

Monitoring

We have identified the issue that was leading to increased latency. We've implemented a solution, and are now closely monitoring while it takes effect.

Thu, Jul 24, 2025, 03:59 PM(48 minutes earlier)

Investigating

We are still seeing increased latency for our text-to-speech requests. We're continuing our investigation.

Thu, Jul 24, 2025, 03:21 PM(37 minutes earlier)

Monitoring

We've identified and addressed the issue causing increased TTS latency. This may take some time to fully take effect, and we are continuing the situation to monitor closely.

Thu, Jul 24, 2025, 02:59 PM(22 minutes earlier)

Investigating

We're currently investigating higher than normal latency for TTS.

Thu, Jul 24, 2025, 01:44 PM(1 hour earlier)