STT Service Degraded
Resolved
Partial outage

Issue resolved

Sat, Mar 22, 2025, 06:53 PM
1 week ago
Affected components
API
Updates

Resolved

Issue resolved

Sat, Mar 22, 2025, 06:53 PM
1h earlier...

Investigating

STT degraded, some requests may fail. Our team is actively investigating the cause

Sat, Mar 22, 2025, 05:39 PM