Resolved
Fix released
Identified
finish_reason changed to "stop" from "tool_calls" for gpt4o. Not related to any package update, rather openai's behavioral change.
Possibly impacted their own visual assistant api with correlating timelines (https://status.openai.com/incidents/92f5s0j26p6w)
Investigating
Tool call invocation causes the call to be hanging. Tool calling with gpt4o-mini works fine. Unclear if issue on OpenAI's side.