Resolved
Our billing provider has corrected the problem, and all subscription updates are processing normally and without delay.
Identified
We have identified an issue related to the billing provider and are implementing measures to mitigate and resolve it.
Investigating
We are currently experiencing an issue with our payment provider that causes a delay when moving from a free plan to a paid plan. In some cases, the upgrade will not be registered in the account until up to 2 hours after payment. We are actively investigating and will post updates as they become available.