ElevenLabs

Help CentreSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Voices not showing up in EU and India data residency workspaces
Resolved·Degraded performance

We have released an update to resolve this issue.

Mon, May 4, 2026, 06:38 PM
(1 month ago)
·
Affected components
May 4, 2026, 03:32 PM
06:38 PM
ElevenCreative
Updates

Resolved

We have released an update to resolve this issue.

Mon, May 4, 2026, 06:38 PM

Identified

We have identified the source of the issue and are releasing an update to resolve it.

Mon, May 4, 2026, 04:12 PM(2 hours earlier)

Investigating

We are currently investigating an issue preventing voices from appearing in EU and India data residency workspaces. Default voices, voices in the 'My Voices' section, and Voice Collections are unaffected.

Mon, May 4, 2026, 03:32 PM(39 minutes earlier)