ElevenLabs

Help CentreSubscribe to updates
Powered by
Privacy policy

·

Terms of service
EU and IN Residency Webpages Inaccessible
Resolved·Partial outage

We have confirmed full functionality of both EU and IN residency webpages.

Mon, Mar 9, 2026, 06:42 PM
(3 months ago)
·
Affected components
Mar 9, 2026, 06:00 PM
06:25 PM
ElevenCreative
Updates

Resolved

We have confirmed full functionality of both EU and IN residency webpages.

Mon, Mar 9, 2026, 06:42 PM

Monitoring

The EU and IN residency pages are currently in a functional state. We are continuing to monitor their health to ensure no further interruptions.

Mon, Mar 9, 2026, 06:30 PM(12 minutes earlier)

Investigating

Currently, https://eu.residency.elevenlabs.io/ and https://in.residency.elevenlabs.io/ are not accessible. We are investigating and working to resolve this.

Mon, Mar 9, 2026, 06:17 PM(12 minutes earlier)